How to install a component for Joomla 1.0.x to 1.5

Joomla 1.5 has a built-in "legacy" plugin which allows extensions that are not compatible with 1.5 to be installed.

You can enable this plugin from your Joomla admin area -> Extensions -> Plugin Manager. In the Filter: field type Legacy and click on Go.  The System-Legacy plugin will appear below. To enable it, simply check the box next to it and then click the Enable button located at the top-right Joomla menu.

However, we would advise you to use components which are fully compatible with Joomla 1.5 in order to avoid any discrepancies and malfunctions in your Joomla application.

Joomla is a powerful software that is easy to work with once you have the right host to support you. Before you lose any more time with the wrong host, check out the SiteGround Joomla hosting offer.