If I upgrade to Joomla 1.5, will my existing components work there?

Please note that the Joomla upgrade from 1.0.x to 1.5 preserves only the content of your old website. You will have to add again all custom components/modules.

Fortunately, Joomla 1.5 has a built-in "legacy" plugin which allows components that are not compatible with 1.5 to be installed. More information on how to enable this plugin is available in this article.

Joomla is a powerful software that is easy to work with once you have the right host to support you. Before you lose any more time with the wrong host, check out the SiteGround Joomla hosting offer.