MODx Installation Tutorial

How to Intall MODx

There are few requirements needed for MODx to work correctly. The SiteGround Shared Hosting account meets them all:

  • Apache 1.3.x - 2.2.x (uses htaccess for Friendly URLs by default)
  • PHP 4.3.11 and above
  • Required extensions:
  • mod_rewrite (for friendly URLs/.htaccess)
  • GD lib (required for captcha and file browser)
  • Freetype (required for captcha)
  • Safe_mode off
  • Register_globals off
  • Memory_limit 32MB or more
  • MySQL 4.1.20 or newer

You will have to use one of the following browsers in order to manage your application properly:

  • Microsoft Internet Explorer 7 and above
  • Mozilla Firefox 3.0 and above
  • Apple Safari 3.1.2 and above

Manual installation of MODx

Installing MODx is very easy. Follow the detailed instructions below and you will have a working MODx script in minutes!

The SiteGround.com video content presented here requires a more recent version of the Adobe Flash Player. If you are you using a browser with JavaScript disabled please enable it now. Otherwise, please update your version of the free Flash Player by downloading here.

SiteGround is not affiliated with or endorsed by the MODx Project or its trademark owners.