Need Joomla hosting crafted with care and expert 24/7 support? Start Here!

Lesson 2: Warning before you start upgrading from Joomla 2.5 to 3

Click CC to enable subtitles

Video Transcription

Before you proceed any further with the upgrade process you should check that your web host is compatible with Joomla 3. This means two things Your web host must be operating PHP version 5.3 and above and must have Magic Quotes disabled. To test this go to the Site menu and select System Information. Here you can see the PHP version , in my case it is 5.4.10 which is fine because the minimum is PHP 5.3. Now we should go to the PHP Settings and the sixth one down Magic Quotes you can see is set to Off. If your PHP version was below 5.3 or Magic Quotes was set to On then you should contact your web host for the exact method to set Magic Quotes to Off and to ensure that PHP is at least version 5.3 on their hosting panel.

Every host has a different way of doing this and only your host can give you the best and quickest way of making the changes. Please note you can make that change now on your Joomla 2.5 web site as it will not break anything. Once you are able to see that your PHP version and your Magic Quotes are reported by by Joomla at the correct settings you can proceed with the upgrade of your Joomla 2.5 web site to Joomla 3.